using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @",(?=(?:[^']*'[^']*')*[^']*$)";
string input = @"count(rtnotes.keyno) as value,ent.company as label, 'j-ChartDrillDown-406,'+CAST(ENT.ENTID AS CHAR(10)) AS link, dateadd(week, datediff(wk, 0, dateadd(wk,-5,getdate())), -1) as test";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}