$re = '/,(?=(?:[^\']*\'[^\']*\')*[^\']*$)/m';
$str = 'count(rtnotes.keyno) as value,ent.company as label, \'j-ChartDrillDown-406,\'+CAST(ENT.ENTID AS CHAR(10)) AS link, dateadd(week, datediff(wk, 0, dateadd(wk,-5,getdate())), -1) as test';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);