use strict;
my $str = 'count(rtnotes.keyno) as value,ent.company as label, \'j-ChartDrillDown-406,\'+CAST(ENT.ENTID AS CHAR(10)) AS link, dateadd(week, datediff(wk, 0, dateadd(wk,-5,getdate())), -1) as test';
my $regex = qr/,(?=(?:[^']*'[^']*')*[^']*$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}