import re
regex = re.compile(r",(?=(?:[^']*'[^']*')*[^']*$)", flags=re.MULTILINE)
test_str = "count(rtnotes.keyno) as value,ent.company as label, 'j-ChartDrillDown-406,'+CAST(ENT.ENTID AS CHAR(10)) AS link, dateadd(week, datediff(wk, 0, dateadd(wk,-5,getdate())), -1) as test"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")