use strict;
my $str = 'подлесок: Р КС ОЛК СР.ГУСТ
подлесок: Р КУЛ СРЕДНИЙ
подлесок: ИВК Р СРЕДНИЙ
подлесок: КУЛ ЛЩ СРЕДНИЙ
подлесок: Ч,Кл,Лщ средний
подлесок: Ч,Кл,Лщ густой
подлесок: ЛЩ ЛС КЛ средний
подлесок: РН СП густой
подлесок: СП РН Ч густой
подлесок: КЛ КС РЕДКИЙ
подлесок: Лщ редкий
подлесок: БРК КРЛ Р
подлесок ЛЩ+КРЛ+ИВК редкий
подлесок ЛЩ+КРЛ редкий';
my $regex = qr/^(?:подлесок:?+)(?:[ ]*+(?<TS1>[а-я]{1,4}|\d+)(?=[ ,+]|$))?+(?:[, +]*+(?<TS2>[а-я]{1,4}|\d+)(?=[, +]|$))?+(?:[, +]*+(?<TS3>[а-я]{1,4}|\d+)(?=[, +]|$))?+(?:[, +]*+(?<TS4>[а-я]{1,4}|(\d+))(?=[, +]|$))?+(?:[, +]*+(?<TS5>[а-я]{1,4}|\d+)(?=[, +]|$))?+(?:,?[ ]*+(?<DENSITY>средний|густой|редкий|ср\.густ|средней|редкой))?.*+$/miup;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}