import re
regex = re.compile(r"^(?:подлесок:?+)(?:[ ]*+(?<TS1>[а-я]{1,4}|\d+)(?=[ ,+]|$))?+(?:[, +]*+(?<TS2>[а-я]{1,4}|\d+)(?=[, +]|$))?+(?:[, +]*+(?<TS3>[а-я]{1,4}|\d+)(?=[, +]|$))?+(?:[, +]*+(?<TS4>[а-я]{1,4}|(\d+))(?=[, +]|$))?+(?:[, +]*+(?<TS5>[а-я]{1,4}|\d+)(?=[, +]|$))?+(?:,?[ ]*+(?<DENSITY>средний|густой|редкий|ср\.густ|средней|редкой))?.*+$", flags=re.MULTILINE | re.IGNORECASE | re.UNICODE)
test_str = ("подлесок: Р КС ОЛК СР.ГУСТ\n"
"подлесок: Р КУЛ СРЕДНИЙ\n"
"подлесок: ИВК Р СРЕДНИЙ\n"
"подлесок: КУЛ ЛЩ СРЕДНИЙ\n"
"подлесок: Ч,Кл,Лщ средний \n"
"подлесок: Ч,Кл,Лщ густой \n"
"подлесок: ЛЩ ЛС КЛ средний\n"
"подлесок: РН СП густой\n"
"подлесок: СП РН Ч густой\n"
"подлесок: КЛ КС РЕДКИЙ\n"
"подлесок: Лщ редкий\n"
"подлесок: БРК КРЛ Р \n"
"подлесок ЛЩ+КРЛ+ИВК редкий\n"
"подлесок ЛЩ+КРЛ редкий")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")