import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^[ \\t]*)Global([^\\n\\;\\/]*);?";
final String string = "Global Base:TList=New TList; // База загруженных спрайтив. Чтобы не грузить одно и то же\n\n"
+ "//цвета ключевых пикселей, испульзуемых в поиске\n"
+ "Global PxAlpha = -GenRgb(0, 0, 0, 0) \n"
+ "Global PxRed = -GenRgb(0, 1, 0, 0) // 65536\n"
+ "Global PxBlack = -GenRgb(1, 0, 0, 0); // 16777216 \n\n"
+ "Global => public static";
final String subst = "$1public static$2;";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}