// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
  let regex = Regex::new(r"(?m)(^[ \t]*)Global([^\n\;\/]*);?").unwrap();
  let string = "Global Base:TList=New TList; // База загруженных спрайтив. Чтобы не грузить одно и то же
//цвета ключевых пикселей, испульзуемых в поиске
Global PxAlpha = -GenRgb(0, 0, 0, 0) 
Global PxRed = -GenRgb(0, 1, 0, 0) // 65536
Global PxBlack = -GenRgb(1, 0, 0, 0); // 16777216 
Global => public static";
  let substitution = "$1public static$2;";
  
  // result will be a String with the substituted value
  let result = regex.replace_all(string, substitution);
  
  println!("{}", result);
}