const regex = /(^[ \t]*)Global([^\n\;\/]*);?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^[ \\t]*)Global([^\\n\\;\\\/]*);?', 'gm')
const str = `Global Base:TList=New TList; // База загруженных спрайтив. Чтобы не грузить одно и то же
//цвета ключевых пикселей, испульзуемых в поиске
Global PxAlpha = -GenRgb(0, 0, 0, 0)
Global PxRed = -GenRgb(0, 1, 0, 0) // 65536
Global PxBlack = -GenRgb(1, 0, 0, 0); // 16777216
Global => public static`;
const subst = `$1public static$2;`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);