using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\""statusCode\"":(?<statusCodeValue>[\d]*)";
string input = @"||INFO||||Response:{""requestId:""369018b6-0fd4-11ee-be56-0242ac120002"",""headers"":{""Content-Type"":[""application/json""]},""url"":""https://sample-service.abcCompany.com"",""statusCode"":200,""method"":""POST"",""timeTaken"":98,""body"":{"".."":"".."",""..."":""...""}}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}