import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\\"statusCode\\\":(?<statusCodeValue>[\\d]*)";
final String string = "||INFO||||Response:{\"requestId:\"369018b6-0fd4-11ee-be56-0242ac120002\",\"headers\":{\"Content-Type\":[\"application/json\"]},\"url\":\"https://sample-service.abcCompany.com\",\"statusCode\":200,\"method\":\"POST\",\"timeTaken\":98,\"body\":{\"..\":\"..\",\"...\":\"...\"}}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}