// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)\"statusCode\":(?<statusCodeValue>[\d]*)"#).unwrap();
let string = "||INFO||||Response:{\"requestId:\"369018b6-0fd4-11ee-be56-0242ac120002\",\"headers\":{\"Content-Type\":[\"application/json\"]},\"url\":\"https://sample-service.abcCompany.com\",\"statusCode\":200,\"method\":\"POST\",\"timeTaken\":98,\"body\":{\"..\":\"..\",\"...\":\"...\"}}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}