re = /\"statusCode\":(?<statusCodeValue>[\d]*)/m
str = '||INFO||||Response:{"requestId:"369018b6-0fd4-11ee-be56-0242ac120002","headers":{"Content-Type":["application/json"]},"url":"https://sample-service.abcCompany.com","statusCode":200,"method":"POST","timeTaken":98,"body":{"..":"..","...":"..."}}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end