package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(([a-zA-Z]:)|(\\{2}\w+\\[\w- ]+[$])|(\\{2}\w+))(\\[\w-. ]*)*(.xml|.XML)$`)
var str = `XX2 03-01-2017.xml`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}