#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=SL{1}\d_)[0-9_]*|(?<=DM{1}\d_)[0-9_].*"
Local $sString = "Input is DM1_SL1_609_604980" & @CRLF & _
"Input is DM1_813_1881" & @CRLF & _
"Input is DM2_793_1808"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")