const regex = /(?<=SL{1}\d_)[0-9_]*|(?<=DM{1}\d_)[0-9_].*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=SL{1}\\d_)[0-9_]*|(?<=DM{1}\\d_)[0-9_].*', 'gm')
const str = `Input is DM1_SL1_609_604980
Input is DM1_813_1881
Input is DM2_793_1808`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}