import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=SL{1}\\d_)[0-9_]*|(?<=DM{1}\\d_)[0-9_].*";
final String string = "Input is DM1_SL1_609_604980\n"
+ "Input is DM1_813_1881\n"
+ "Input is DM2_793_1808";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}