using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=SL{1}\d_)[0-9_]*|(?<=DM{1}\d_)[0-9_].*";
string input = @"Input is DM1_SL1_609_604980
Input is DM1_813_1881
Input is DM2_793_1808";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}