using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"amountValue..\:.\""(?P<amountValue>.*?).\""\,";
string input = @"\""amountLabel\"":\""Amount\"",\""amountValue\"":\""6000.00\"",\""sentOrDepositLabel\""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}