re = /amountValue..\:.\"(?P<amountValue>.*?).\"\,/m
str = '\\"amountLabel\\":\\"Amount\\",\\"amountValue\\":\\"6000.00\\",\\"sentOrDepositLabel\\"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end