package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)amountValue..\:.\"(?P<amountValue>.*?).\"\,`)
var str = `\"amountLabel\":\"Amount\",\"amountValue\":\"6000.00\",\"sentOrDepositLabel\"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}