#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=S—CLOAD NO )\w+"
Local $sString = "S—CLOAD NO A12345-AAB ARGRG" & @CRLF & _
"S—CLOAD NO A127921-SM001 RWGRW" & @CRLF & _
"S—CLOAD NO A133—AAB NOFAFNER"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")