re = /(?<=S—CLOAD NO )\w+/m
str = 'S—CLOAD NO A12345-AAB ARGRG
S—CLOAD NO A127921-SM001 RWGRW
S—CLOAD NO A133—AAB NOFAFNER'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end