import re
regex = re.compile(r"(?<=S—CLOAD NO )\w+", flags=re.MULTILINE)
test_str = ("S—CLOAD NO A12345-AAB ARGRG\n"
"S—CLOAD NO A127921-SM001 RWGRW\n"
"S—CLOAD NO A133—AAB NOFAFNER")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")