import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\p{L}\\p{Mn}\\p{Pd}]*[\\p{Lu}\\p{Ll}\\p{Lt}\\p{Lo}]+[\\p{L}\\p{Mn}\\p{Pd}]*[\\p{L}\\p{Mn}\\p{Pd}]*";
final String string = "Creatinin/Serum² ";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}