import Foundation
// WARNING: You included a flag that Swift doesn't support: u
// When this flag is set, it makes the pattern and subject strings to be treated as unicode.
// Swift already treats the pattern and subject strings as unicode by default, so including this flag is redundant.
let pattern = #"[\p{L}\p{Mn}\p{Pd}]*[\p{Lu}\p{Ll}\p{Lt}\p{Lo}]+[\p{L}\p{Mn}\p{Pd}]*[\p{L}\p{Mn}\p{Pd}]*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Creatinin/Serum² "#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}