const regex = /[\p{L}\p{Mn}\p{Pd}]*[\p{Lu}\p{Ll}\p{Lt}\p{Lo}]+[\p{L}\p{Mn}\p{Pd}]*[\p{L}\p{Mn}\p{Pd}]*/u;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\p{L}\\p{Mn}\\p{Pd}]*[\\p{Lu}\\p{Ll}\\p{Lt}\\p{Lo}]+[\\p{L}\\p{Mn}\\p{Pd}]*[\\p{L}\\p{Mn}\\p{Pd}]*', 'u')
const str = `Creatinin/Serum² `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}