#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\(([^\)]*)\) started playing (.*?\b)(?: - ([^\.]+))?\.$"
Local $sString = "hyper_d (Galaxy S9) started playing King of the Hill - Episode 419." & @CRLF & _
"" & @CRLF & _
"hyper_d (Galaxy S9) started playing Mr. & Mrs. Smith." & @CRLF & _
"" & @CRLF & _
"hyper_d (Galaxy S9) started playing Kick-Ass." & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")