re = /\(([^\)]*)\) started playing (.*?\b)(?: - ([^\.]+))?\.$/m
str = 'hyper_d (Galaxy S9) started playing King of the Hill - Episode 419.
hyper_d (Galaxy S9) started playing Mr. & Mrs. Smith.
hyper_d (Galaxy S9) started playing Kick-Ass.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end