$re = '/\(([^\)]*)\) started playing (.*?\b)(?: - ([^\.]+))?\.$/m';
$str = 'hyper_d (Galaxy S9) started playing King of the Hill - Episode 419.
hyper_d (Galaxy S9) started playing Mr. & Mrs. Smith.
hyper_d (Galaxy S9) started playing Kick-Ass.
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);