# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\s*@\s+\d+\s+ML$//gm;t' <<< "BX-5VL @ 6 ML
BX-5VL @ 8 ML
BX-5VL @ 15 ML"