import re
regex = re.compile(r"\s*@\s+\d+\s+ML$", flags=re.MULTILINE)
test_str = ("BX-5VL @ 6 ML\n"
"BX-5VL @ 8 ML\n"
"BX-5VL @ 15 ML")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)