const regex = /\s*@\s+\d+\s+ML$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s*@\\s+\\d+\\s+ML$', 'gm')
const str = `BX-5VL @ 6 ML
BX-5VL @ 8 ML
BX-5VL @ 15 ML`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);