$re = '/\s*@\s+\d+\s+ML$/m';
$str = 'BX-5VL @ 6 ML
BX-5VL @ 8 ML
BX-5VL @ 15 ML';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;