package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[I,V,X]{1,3}.`)
var str = `IX. století
Matematika pro VII. třídu
Game of Thrones III
Karel IV.
papež Benedict V.
Bělá je X. část statutárního města Děčín.
III. patro
II. stupeň povodňové aktivity`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}