import re
regex = re.compile(r"[I,V,X]{1,3}.", flags=re.MULTILINE)
test_str = ("IX. století\n"
"Matematika pro VII. třídu\n"
"Game of Thrones III\n"
"Karel IV.\n"
"papež Benedict V.\n"
"Bělá je X. část statutárního města Děčín.\n"
"III. patro\n"
"II. stupeň povodňové aktivity")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")