const regex = /(?<inner>(?<![\p{L}'])(?:\p{L}+')+\p{L}+(?![\p{L}']))|
(?<began>(?<!\p{L})(?:'\p{L}+)+(?![\p{L}']))|
(?<ended>(?<![\p{L}'])(?:\p{L}+')+(?!\p{L}))|
(?<outer>(?<!\p{L})'\p{L}+'(?!\p{L}))/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<inner>(?<![\\p{L}\'])(?:\\p{L}+\')+\\p{L}+(?![\\p{L}\']))|
(?<began>(?<!\\p{L})(?:\'\\p{L}+)+(?![\\p{L}\']))|
(?<ended>(?<![\\p{L}\'])(?:\\p{L}+\')+(?!\\p{L}))|
(?<outer>(?<!\\p{L})\'\\p{L}+\'(?!\\p{L}))', 'gmi')
const str = `'Twas---Wha'? Wouldn'tcha'? 'Twas, or 'twasn't, 'tis what's 'tween dawn 'n' dusk 'n stuff. Cookin'? 'Sams' place, 'yo'`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}