re = /(?<inner>(?<![\p{L}'])(?:\p{L}+')+\p{L}+(?![\p{L}']))|
(?<began>(?<!\p{L})(?:'\p{L}+)+(?![\p{L}']))|
(?<ended>(?<![\p{L}'])(?:\p{L}+')+(?!\p{L}))|
(?<outer>(?<!\p{L})'\p{L}+'(?!\p{L}))/mix
str = '\'Twas---Wha\'? Wouldn\'tcha\'? \'Twas, or \'twasn\'t, \'tis what\'s \'tween dawn \'n\' dusk \'n stuff. Cookin\'? \'Sams\' place, \'yo\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end