$re = '/(?<inner>(?<![\p{L}\'])(?:\p{L}+\')+\p{L}+(?![\p{L}\']))|
(?<began>(?<!\p{L})(?:\'\p{L}+)+(?![\p{L}\']))|
(?<ended>(?<![\p{L}\'])(?:\p{L}+\')+(?!\p{L}))|
(?<outer>(?<!\p{L})\'\p{L}+\'(?!\p{L}))/mix';
$str = '\'Twas---Wha\'? Wouldn\'tcha\'? \'Twas, or \'twasn\'t, \'tis what\'s \'tween dawn \'n\' dusk \'n stuff. Cookin\'? \'Sams\' place, \'yo\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);