using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?i)Create(?-i)\b\s*(?:\b.+\s*)*\(\s*""\s*.+\s+(?:\w+\s*)+""";
string input = @"creATe fsfsfsf (""mustHaveThisWord mustHaveThisWordOrMoreWordsAfter third"" Number Not Null)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}