re = /\b(?i)Create(?-i)\b\s*(?:\b.+\s*)*\(\s*"\s*.+\s+(?:\w+\s*)+"/m
str = 'creATe fsfsfsf ("mustHaveThisWord mustHaveThisWordOrMoreWordsAfter third" Number Not Null)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end