import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(~[0-9.% ]+.* )?price increase(.*~[0-9.%]+)?";
final String string = "After price increase of ~0.1% vs others in Year 2020:\n"
+ "After ~6% - 7% price increase vs others in Year 2019:\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}