$re = '/(~[0-9.% ]+.* )?price increase(.*~[0-9.%]+)?/m';
$str = 'After price increase of ~0.1% vs others in Year 2020:
After ~6% - 7% price increase vs others in Year 2019:
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);