use strict;
my $str = 'After price increase of ~0.1% vs others in Year 2020:
After ~6% - 7% price increase vs others in Year 2019:
';
my $regex = qr/(~[0-9.% ]+.* )?price increase(.*~[0-9.%]+)?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}