use strict;
my $str = '/var/www/html/domain.example/web/www/images/gallery/3_preview.png';
my $regex = qr/.*\/www(.*)/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";