# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*\\/www(.*\\/).*/$1/gm;t' <<< "/var/www/html/domain.example/web/www/images/gallery/3_preview.png"