re = /.*\/www(.*\/).*/m
str = '/var/www/html/domain.example/web/www/images/gallery/3_preview.png'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result