import re
regex = re.compile(r".*\/www(.*\/).*", flags=re.MULTILINE)
test_str = "/var/www/html/domain.example/web/www/images/gallery/3_preview.png"
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)