package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*\/www(.*\/).*`)
var str = `/var/www/html/domain.example/web/www/images/gallery/3_preview.png`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}