#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:\d+(?::[0-5][0-9]:[0-5][0-9])?|[0-5]?[0-9]:[0-5][0-9])$"
Local $sString = "1:01:12" & @CRLF & _
"3" & @CRLF & _
"1233:23:45" & @CRLF & _
"2:59:59" & @CRLF & _
"34:34" & @CRLF & _
"1234" & @CRLF & _
"99" & @CRLF & _
"59:59" & @CRLF & _
"6:12" & @CRLF & _
"" & @CRLF & _
"59:60" & @CRLF & _
"2:59:60" & @CRLF & _
"6:" & @CRLF & _
"1:1:12" & @CRLF & _
"2:59:59:45" & @CRLF & _
"" & @CRLF & _
"66:12" & @CRLF & _
"1:1:12"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")